DNSSec issues between root (.) and ch TLD
Minor incident
External Services
DNS-Providers
2025-01-31 10:28 CET
· 8 minutes
Updates
Resolved
January 31, 2025 · 10:36 CET
at this moment Switch seems to have fixed the issue. Delegation is fine again
Issue
January 31, 2025 · 10:28 CET
We’re currently seeing possible issues for DNSSec enabled domains in the CH TLD. It looks like the DNSSec delegation between the root zone (.) and the CH zone is borked. There is nothing that SEPPmail can do about it. We informed our contact at Switch (NIC).
The issue may affect mail transmission if sender and/or recipient are in CH zone and have DNSSec enabled
← Back