Swisssign Outage

Major incident Global Services Swisssign Certificate Authority
2025-02-24 22:00 CET · 12 hours, 28 minutes

Updates

Resolved

The issue seems to be fixed at Swisssign, we see successful deployments of services again.

We will keep monitoring the situation but declare the incident closed from our side.

February 25, 2025 · 10:28 CET
Investigating

Restore of production services at Swisssign is ongoing. It is expected to take approximately an hour (current time: 2025-02-25 08:30 CET) for one of the backend services to recover.

An official information from Swisssign will follow soon.

February 25, 2025 · 08:27 CET
Investigating

According to Swisssign, the situation has been successfully remediated in their pre-production environment, and they are confident that production can be fixed soon as well.

February 25, 2025 · 07:46 CET
Issue

Since an announced maintenace (2025-02-24 18:00-22:00 CET), the services of Swisssign have been unavailable. Access requests to Swisssign Certificate Endpoints are either redirected to the maintenance status page or result in a 403 error from Cloudflare.

We alerted Swisssign overnight and are awaiting their feedback for the reasons of the outage and a fix.

This affects the following services:

  • Issuing certificates for new users
  • Renewing certificates for existing users (as we attempt renewal 30 days before expiration, the impact here is not noticeable)
  • Performing domain validation for new services.

We will update this incident within an hour.

February 25, 2025 · 07:20 CET

← Back