Manitu Rejects

Minor incident Mailflow CH Instance Mailflow EU Instance CH Instance EU Instance External Services DNS-Providers Non-SEPPmail-related incidents
2025-03-07 09:24 CET · 1 hour, 26 minutes

Updates

Resolved

The listing has been removed again. Apparently the listing was intentional to encourage mail operators to remove Manitu RBL from their setup. We thus expect this issue to occur again in the near future.

March 7, 2025 · 10:43 CET
Issue

We see some outbound messages being rejected due to “Message refused by DNSBL check. ix.dnsbl.manitu.net”.
A few weeks ago Manitu RBL shut down. While they promised RFC compliant shutdown procedure they are now listing every IP address. Thus any mail server still querying this RBL will mark or reject many mails as false positive spam.
This is not an issue of the SEPPmail Cloud. We recommend contacting affected recipients respectively their systems administrator via alternative communications channels and advise them to remove Manitu RBL from their spam filter setup.

March 7, 2025 · 09:24 CET

← Back