cloud stability issues

Minor incident Mailflow CH Instance Login Page GINA Interface Cloud REST API Mailflow EU Instance Global Services CH Instance EU Instance Quarantine Reports
2025-04-04 09:51 CEST · 1 week, 4 hours, 29 minutes

Updates

Resolved

After update the system has gone back to normal stability.

April 11, 2025 · 14:19 CEST
Monitoring

We have updated all appliances with patches that should improve stability and performance. We keep monitoring the situation before we close this incident.

April 10, 2025 · 14:44 CEST
Issue

Currently we experience some stability issues of our cloud appliances. Developers are investigating the cause while our sysadmin team is working permanently on maintaining the availability of the cloud. Short term outages may be possible at any time, though.
If login to the Cloud UI returs an error, please try again a few minutes later.
Some mail may be delayed, but no mail is lost.

April 4, 2025 · 09:51 CEST

← Back