DNS Server problems with Hostpoint

Minor incident External Services DNS-Providers
2025-06-05 15:10 CEST · 18 hours, 8 minutes

Updates

Resolved

According to our latest checks the issue seems to be resolved.

June 6, 2025 · 09:18 CEST
Issue

We’re currently seeing DNS problems with domains which are DNS-hosted with Swiss provider Hostpoint. This may affect mailflow from and to such domains. Our systems will temp rejects such mails as the domains could not be resolved in DNS at the moment.

Updates can be found here: https://www.hostpoint-status.com/

June 5, 2025 · 15:10 CEST

← Back