CH cloud stability issues

Minor incident Mailflow CH Instance Login Page GINA Interface Cloud REST API Global Services CH Instance
2025-06-11 11:31 CEST · 1 hour, 30 minutes

Updates

Resolved

All database instances are running again and are synced to same state. All queued mail has been processed.

June 11, 2025 · 12:58 CEST
Issue

We are encountering issues with the database in the CH cloud instance. This may lead to intermittent availability of the cloud services. mail may be delayed. Our technicians are actively working on it.

June 11, 2025 · 11:31 CEST

← Back