CH cloud stability issues

Minor incident Mailflow CH Instance GINA Interface CH Instance
2025-06-12 11:04 CEST · 6 hours, 28 minutes

Updates

Resolved

we have implemented a few fixes and workarounds to increase stability.

June 12, 2025 · 17:32 CEST
Issue

We encounter stability issues in a portion of the CH cloud instances. This may result in intermittent availability of GINA webmail services and LFT. Some mail may be delayed.

June 12, 2025 · 11:04 CEST

← Back