Proofpoint not reachable

Minor incident External Services Non-SEPPmail-related incidents
2025-07-14 15:38 CEST · 10 hours, 11 minutes

Updates

Resolved

The issue was resolved by Proofpoint. Their DNS records can be resolved again and mailflow has been restored

July 15, 2025 · 01:48 CEST
Issue

Proofpoint cloud has not been reachable since 14:30 because DNSSec of domain pphosted.com is currently broken, see: https://dnsviz.net/d/pphosted.com/dnssec/

SEPPmail Cloud validates DNSSec as it is required for DANE and to improve general Email transfer security.

This means that mail to any recipient on Proofpoint cloud is currently queued on our relay hosts. Sending is retried for up to 24h before a Bounce/NDR would be returned to the sender. The error message will look like this:
Host or domain name not found. Name service error for name=mxb-xxxxxxx.gslb.pphosted.com type=A: Host not found, try again

Mail sent from Proofpoint Cloud is mostly temporarily rejected due to various DNS resolution related verification failures. Proofpoint should keep mail in their queue and periodically retry sending.

There is nothing SEPPmail Cloud can do. The issue must be fixed by Proofpoint.

July 14, 2025 · 15:38 CEST

← Back