Datacenters networking issue
      
Major incident
      
        Mailflow CH Instance
        GINA Interface
        CH Instance
    
    
      
2025-08-13 16:45 CEST
      
      · 30 minutes
    
  Updates
          Resolved
        
        
August 13, 2025 · 17:13 CEST
        
      
      The issue has been resolved. Delayed mails should arrive with delays but no mail should have been lost or rejected.
          Issue
        
        
August 13, 2025 · 17:01 CEST
        
      
  One of our cloud location is having connectivity issues with another one. Some services and mail traffic might be affected. We are investigating the issue and working hard to resolve it.
← Back