SEPPmail Cloud problems with login
Minor incident
Login Page
Global Services
2025-10-31 07:44 CET
· 1 hour, 21 minutes
Updates
Resolved
October 31, 2025 · 09:04 CET
we found the root cause for the issue and our development fixed it. It looks that only SEPPmail users were affected. The issue has not affected customer oder customer admin users. Their logins always worked
Investigating
October 31, 2025 · 07:51 CET
it looks like only a subset of users is affected. Customers and customer admins may still be able to login
Issue
October 31, 2025 · 07:44 CET
we’re currently experiencing login issues with our cloud login. We’re investigating and will update this incident.
← Back