SEPPmail Website Down
Minor incident
Website
2026-01-29 10:21 CET
· 1 hour, 12 minutes
Updates
Resolved
January 29, 2026 · 11:31 CET
All language version of the website are accessible again. There may still be smaller outages in the afternoon when webmasters want to roll out small fixes and perform some reliability tests.
Issue
January 29, 2026 · 10:21 CET
Our website is currently unavailable in German, French, and Spanish. The webmaster team is analyzing the issue.
Please refer to the English version https://seppmail.com/ to retrieve any marketing or contact information.
Other web based services such as documentation, SEPPmail Cloud GINA web interface or SEPPmail Cloud Console are not affected. The mail flow in SEPPmail Cloud is not affected.
← Back