Mailflow problem in CH
Minor incident
Mailflow CH Instance
Login Page
GINA Interface
Global Services
CH Instance
2026-03-04 22:00 CET
· 53 minutes
Updates
Resolved
March 4, 2026 · 22:50 CET
Provider could solve the issue. Our tests show that our environment is stable again and the components are in sync between the DCs
During that time no mail could be processed in our CH cloud. Currently mailflow is established again.
De-escalate
March 4, 2026 · 22:48 CET
Our provider confirms the issue and it could be resolved in the meantime
Issue
March 4, 2026 · 22:31 CET
We’re currently experiencing an issue with the mailflow in CH. Our technicians are working on investigating the issue. I looks like mailflow is affected in both CH datacenters.
← Back