Delay issuing SwissSign S/MIME certificates in DE cloud

Minor incident Mailflow EU Instance EU Instance
2026-03-16 10:29 CET · 2 hours, 42 minutes

Updates

Resolved

Gemäss unseren Protokollen scheint das Problem seit ca 12 Uhr behoben zu sein.

March 16, 2026 · 13:11 CET
Issue

We currently encounter timeouts while contacting SwissSigns MPKI service from our backend servers in the DE instance of SEPPmail Cloud. This may lead to significant delays of individual mails of new users without existing certificate. We are working with SwissSign on resolving this issue.

Generally there are various recent changes in interaction with SwissSign services affecting all customers in all instances of SEPPmail Cloud and onprem:
Please ensure the latest swisssign-check DNS record was published.
Also ensure exactly one swisssign-check DNS record exists in the zone.
Outdated or multiple records prevent issuing new certificates.

March 16, 2026 · 10:29 CET

← Back