Delivery issue to Incamail

Minor incident External Services Non-SEPPmail-related incidents
2026-04-08 08:31 CEST · 1 week, 7 hours, 36 minutes

Updates

Update

Incamail disabled the problematic certificate checks on connections from our delivery systems for the sender domains we provided to them. Therefore sending to Incamail via SEPPmail Cloud should work again. We still wait for a proper certificate from them that contains the required capabilities to interact on TLS connections to Incamail

April 17, 2026 · 09:57 CEST
Resolved

We have finally established communications with incamail and they allow traffic from our servers again. A permanent solution is still to be implemented, but customers should no longer be affected.

April 15, 2026 · 16:06 CEST
Issue

Currently we encounter difficulties submitting mail from SEPPmail Cloud CH instance to Incamail servers, as Incamail defers some mail with the following message:

host gw2.incamail.com[194.41.147.14] said: 451 4.7.1 Certificate EKU validation failed, please retry later (in reply to end of DATA command)

Delivery of such mail is being retried, and mail remains in our queues for up to 24 hours.

We have tried to contact Incamail and are awaiting their response.

April 8, 2026 · 08:31 CEST

← Back