CH cloud: connectivity issues
Minor incident
Mailflow CH Instance
Login Page
GINA Interface
Cloud REST API
Global Services
CH Instance
2026-04-30 07:36 CEST
· 2 hours, 59 minutes
Updates
Resolved
April 30, 2026 · 10:34 CEST
All queues have been processed and mail flow is back to normal.
Update
April 30, 2026 · 09:29 CEST
One of our hosting providers found a flapping network interface on one of their routers. Once they disabled the interface our VPN connections immediately stabilized and in consequence the cluster resumed normal operations.
There is still a high number of messages in our queues, which means delays are still occurring, but we expect the situation to clear up within the next hour.
Issue
April 30, 2026 · 07:36 CEST
Currently we encounter connectivity issues between the different data centre locations of the CH cloud instance. So far no data or mail has been lost, but mail processing is very slow and mail is being delayed. We are investigating the cause and implement workarounds and mitigations.
← Back