CH cloud: delays due to outage at hosting provider
Minor incident
Mailflow CH Instance
Login Page
GINA Interface
Cloud REST API
Global Services
CH Instance
2026-05-11 09:20 CEST
· 3 hours, 28 minutes
Updates
Investigating
May 11, 2026 · 11:34 CEST
According to our provider:
Currently there are network issues on our border, impacting incoming and outgoing traffic to / from the public internet. Our network team is currently analysing the root-cause. As soon as we have more information we will update you.
We sincerely apologize for the inconvenience caused and thank you for your understanding.
Issue
May 11, 2026 · 09:38 CEST
One of our hosting provider encounters network issues. Our VPN between data centres is broken. As a consequence some internal communication of our cluster is interrupted. We are working on a bypass to re-enable full mail processing. Some mail is being queued and will be delivered with delay. No loss of mail or permanent reject is expected.
← Back