CH Cloud: delays after maintenance

Minor incident Mailflow CH Instance CH Instance
2026-05-28 16:43 CEST · 4 days, 23 hours, 43 minutes

Updates

Resolved

After rolling out various patches to improve mail processing performance back to previous levels and increasing resources we are confident our cluster is again able to handle customer traffic.

June 2, 2026 · 16:25 CEST
Monitoring

After increasing resources and applying a few patches targeting performance regressions the queues have been at normal levels since weekend.

June 2, 2026 · 09:30 CEST
Investigating

Currently queues are empty and mail is processed without additional delay. We keep monitoring the situation and will continue to improve performance.

May 29, 2026 · 13:20 CEST
Investigating

Situation is slightly better, we are still working on a proper resolution.

May 29, 2026 · 09:26 CEST
Issue

We currently encounter performance issues after appliance update. Our operations team is working on mitigations while the development team is investigating the cause.

As a consequence mail is currently delayed. We do not expect any mail to be lost.

May 28, 2026 · 16:43 CEST

← Back