DE/CH Cloud: delays due to M365 rate limits

Minor incident Mailflow CH Instance Mailflow EU Instance CH Instance EU Instance
2026-06-02 15:35 CEST · 2 hours, 5 minutes

Updates

Monitoring

Microsoft 365 is currently returning temporary throttling responses during message handover, so affected emails remain queued on our side and will be retried automatically for up to 10 days or until Microsoft accepts delivery.

Apparently we are not the only ones affected:
https://status.codetwo.com/
https://www.reddit.com/r/sysadmin/comments/1tuqw17/exchange_online_issues_421_432_the_maximum_number/

June 2, 2026 · 16:28 CEST
Investigating

According to our investigation the issue started at 14:01, affecting all our servers at once. We can only assume that Microsoft rolled out new rate-limits.
It also affects customers in CH cloud, not only DE cloud, and also inline outbound traffic. Determining factor is the hosting forest of the recipient. Currently we see issues only when delivering to hosts whose MX A records point to M365 IPs in 52.101.168.0/24, 52.101.170.0/24, 2a01:111:f403:ca2d::/64, 2a01:111:f403:ca27::/64 which seem to be located in M365’s German/EU hosting zone.

June 2, 2026 · 16:17 CEST
Issue

Microsoft M365 suddenly started to rate limit our IP ranges. This leads to delays of mail delivered to inline customers hosted at M365 and messages sent to or from parallel customers hosted at M365.

We try to get in touch with M365 to figure out reasons, possible workarounds, and solutions. In case any partner or customer has good contacts to Microsoft please assist us by opening support cases with M365.

The rate limit message is: 421 4.3.2 The maximum number of concurrent connections per resource forest has exceeded a limit, closing transmission channel. pod72038ehf.outlook.com. PRX8 [Name=InboundProxyTrackingAgent]

June 2, 2026 · 15:35 CEST

← Back