CH cloud: performance degradation

Minor incident Mailflow CH Instance CH Instance
2026-06-15 10:57 CEST · 2 hours, 56 minutes

Updates

Resolved

mail flow is back to normal.

June 15, 2026 · 13:53 CEST
Issue

Currently we encounter slow performance of parallel outbound traffic which leads to some delay. Our teams are investigating the cause.

June 15, 2026 · 10:57 CEST

← Back