Performance degradation in CH cloud

Minor incident Mailflow CH Instance CH Instance
2026-06-16 16:11 CEST · 1 hour, 6 minutes

Updates

Resolved

queues are down again. We still investigate the root cause

June 16, 2026 · 17:17 CEST
Issue

Currently we encounter slow performance of parallel outbound traffic which leads to some delay. Our teams are investigating the cause.

June 16, 2026 · 16:11 CEST

← Back