DE/CH Cloud: delays due to M365 rate limits

Minor incident External Services M365 Mailhosting
2026-09-04 11:07 CEST · 9 hours, 2 minutes

Updates

Resolved

All queued mail could be delivered and new mail is currently accepted on first try.

September 4, 2026 · 20:08 CEST
Monitoring

According to wide spread reports on the internet the issue seems to lie with M365:
https://www.reddit.com/r/sysadmin/comments/1w6yw7g/exchange_online_server_busy_please_try_again/
https://allestörungen.de/stoerung/microsoft-365/?nogeo=true

Just now we see that the queues have started to slowly come down. We keep monitoring the situation.

September 4, 2026 · 15:38 CEST
Issue

Microsoft M365 suddenly started to rate limit our IP ranges. This leads to delays of mail delivered to inline customers hosted at M365 and messages sent to or from parallel customers hosted at M365.

We try to get in touch with M365 to figure out reasons, possible workarounds, and solutions. In case any partner or customer has good contacts to Microsoft please assist us by opening support cases with M365.

The rate limit message is: 451 4.7.500 Server busy. Please try again later from [x.x.x.x]. (S7 7719)

September 4, 2026 · 11:07 CEST

← Back