Delays on CH cloud with one of our providers

Minor incident Mailflow CH Instance CH Instance
2026-09-18 15:31 CEST · 51 minutes

Updates

Resolved

The processing time is back to normal. Out technicians solved the issue by starting the database connection. We’re still monitoring our queues closely

September 18, 2026 · 16:21 CEST
Issue

We’re seeing delays in processing of messages in CH cloud with one of our hosting providers. We’re investigating the case with high priority. No mail will be losts!

September 18, 2026 · 15:56 CEST

← Back